Unplanned Downtime

Major incident Ecomz public site Ecomz admin site
2022-01-05 08:42 EEST · 33 minutes

Updates

Resolved

We found the root of the issue and we have fixed it.

January 5, 2022 · 09:15 EEST
Issue

Our servers are currently experiencing an issue. You might not be able to access your remote computers at this time. Our engineers are working to resolve it as soon as possible. We apologize for the inconvenience.

January 5, 2022 · 08:43 EEST

← Back