Scheduled Maintenance Announcement

Major incident Ecomz public site Ecomz admin site
2022-02-20 22:42 EEST · 20 minutes

Updates

Resolved

The Hotfix has been completed. Thanks for being patient.

February 20, 2022 · 23:03 EEST
Issue

We will perform system maintenance on XXXXXX. You may experience service interruption and account login failures during this time. We apologize for any inconvenience.

February 20, 2022 · 22:43 EEST

← Back